Checks whether the category can be hidden in the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool CanCategoryBeHidden( ElementId elementId ) |
Visual Basic |
---|
Public Function CanCategoryBeHidden ( _ elementId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool CanCategoryBeHidden( ElementId^ elementId ) |
Parameters
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
ElementId of the category.
Return Value
True if the category can be hidden, false otherwise.
Remarks
Categories can be allowed to be hidden in some view types and prohibited from being hidden in others.
E.g., categories cannot be hidden in ProjectBrowser
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |