Gets or sets the current checked ToggleButton of the RadioButtonGroup.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public ToggleButton Current { get; set; } |
Visual Basic |
---|
Public Property Current As ToggleButton Get Set |
Visual C++ |
---|
public: property ToggleButton^ Current { ToggleButton^ get (); void set (ToggleButton^ value); } |
Remarks
The default value is the first ToggleButton added to the group.
When using this property to set the current ToggleButton, the external command of that button will not be called.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when trying to set this property to nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when trying to set this property to a button not in this group. |