Gets the writable section data object.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public TableSectionData GetSectionData( SectionType sectionType ) |
Visual Basic |
---|
Public Function GetSectionData ( _ sectionType As SectionType _ ) As TableSectionData |
Visual C++ |
---|
public: TableSectionData^ GetSectionData( SectionType sectionType ) |
Parameters
- sectionType
- Type: Autodesk.Revit.DB..::..SectionType
Return Value
The table section data object.
Remarks
Access to this information requires an open transaction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |