Gets the LinePattern associated to an element or from a built-in line pattern.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static LinePattern GetLinePattern( Document document, ElementId elementId ) |
Visual Basic |
---|
Public Shared Function GetLinePattern ( _ document As Document, _ elementId As ElementId _ ) As LinePattern |
Visual C++ |
---|
public: static LinePattern^ GetLinePattern( Document^ document, ElementId^ elementId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document in which to retrieve the LinePattern.
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the LinePatternElement or the built-in line pattern id.
Return Value
A copy of LinePattern object. nullNothingnullptra null reference (Nothing in Visual Basic) if the ElementId doesn't represent a line pattern element or built-in line pattern. nullNothingnullptra null reference (Nothing in Visual Basic) for Solid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |