Returns the workset from a input WorksetId.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public Workset GetWorkset( WorksetId id ) |
Visual Basic |
---|
Public Function GetWorkset ( _ id As WorksetId _ ) As Workset |
Visual C++ |
---|
public: Workset^ GetWorkset( WorksetId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..WorksetId
Id of a workset.
Return Value
The returned workset. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no workset in this table with this Id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |