Starts an stairs edit mode for an existing Stairs element
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ElementId Start( ElementId stairsId ) |
Visual Basic |
---|
Public Function Start ( _ stairsId As ElementId _ ) As ElementId |
Visual C++ |
---|
public: ElementId^ Start( ElementId^ stairsId ) |
Parameters
- stairsId
- Type: Autodesk.Revit.DB..::..ElementId
The stairs element to be edited.
Return Value
ElementId of the editing stairs. It should be the same as the input stairsId
Remarks
User will need to start a transaction to actually make changes to the stairs element.
StairsEditScope can only be started when there is no transaction active
Thus it does not work for commands running in automatic transaction mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a Stair's id. -or- Stairs is not permitted to edit at this moment for the following reason: The Stairs is in an ElementGroup and it is not in Edit Group Mode. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | StairsEditScope is not permitted to start at this moment for one of the following reasons: The document is in read-only state, or the document is currently modifiable, or there already is a stairs edit mode active in the document. |