Move the circuits in the source slot to the specific slot.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void MoveSlotTo(
int nMovingRow,
int nMovingCol,
int nToRow,
int nToCol
) |
Visual Basic |
---|
Public Sub MoveSlotTo ( _
nMovingRow As Integer, _
nMovingCol As Integer, _
nToRow As Integer, _
nToCol As Integer _
) |
Visual C++ |
---|
public:
void MoveSlotTo(
int nMovingRow,
int nMovingCol,
int nToRow,
int nToCol
) |
Parameters
- nMovingRow
- Type: System..::..Int32
The Row Number of cell to be moved.
- nMovingCol
- Type: System..::..Int32
Start Column Number of cell to be moved.
- nToRow
- Type: System..::..Int32
The Row Number of cell to moved to.
- nToCol
- Type: System..::..Int32
End Column Number of cell to moved to.
Remarks
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException |
The given row number nMovingRow is invalid in Body.
-or-
The given column number nMovingCol is invalid in Body.
-or-
The given row number nToRow is invalid in Body.
-or-
The given column number nToCol is invalid in Body.
-or-
There is no circuit at given cell (nMovingRow, nMovingCol).
-or-
Cannot move the circuits at slot (nMovingRow, nMovingCol) to given slot (nToRow, nToCol).
|
See Also