Creates a new Solid which is the transformation of the input Solid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public static Solid CreateTransformed( Solid solid, Transform transform ) |
Visual Basic |
---|
Public Shared Function CreateTransformed ( _ solid As Solid, _ transform As Transform _ ) As Solid |
Visual C++ |
---|
public: static Solid^ CreateTransformed( Solid^ solid, Transform^ transform ) |
Parameters
- solid
- Type: Autodesk.Revit.DB..::..Solid
The input solid to be transformed.
- transform
- Type: Autodesk.Revit.DB..::..Transform
The transform (which must be conformal).
Return Value
The newly created Solid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero. |