Checks whether an accuracy is valid for a given display unit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidAccuracy(ForgeTypeId, double)` overload instead.")] public static bool IsValidAccuracy( DisplayUnitType displayUnit, double accuracy ) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidAccuracy(ForgeTypeId, double)` overload instead.")> _ Public Shared Function IsValidAccuracy ( _ displayUnit As DisplayUnitType, _ accuracy As Double _ ) As Boolean |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `IsValidAccuracy(ForgeTypeId, double)` overload instead.")] public: static bool IsValidAccuracy( DisplayUnitType displayUnit, double accuracy ) |
Parameters
- displayUnit
- Type: Autodesk.Revit.DB..::..DisplayUnitType
The display unit.
- accuracy
- Type: System..::..Double
The accuracy to check.
Return Value
True if the accuracy is valid, false otherwise.
Remarks
See the Accuracy property for details on
valid accuracy values.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | displayUnit is an invalid display unit. See UnitUtils.IsValidDisplayUnit(DisplayUnitType) and UnitUtils.GetValidDisplayUnits(). |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |