Export elements of this category in energy analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public ElementId ExportCategory { get; set; }
Visual Basic
Public Property ExportCategory As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ ExportCategory {
	ElementId^ get ();
	void set (ElementId^ value);
}

Remarks

Export will be based on the space type associated with the product creating it. Valid categories are Rooms or MEP Spaces.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL

See Also