Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static double CalculateTimeZone( double latitude, double longitude ) |
Visual Basic |
---|
Public Shared Function CalculateTimeZone ( _ latitude As Double, _ longitude As Double _ ) As Double |
Visual C++ |
---|
public: static double CalculateTimeZone( double latitude, double longitude ) |
Parameters
- latitude
- Type: System..::..Double
The latitude.
- longitude
- Type: System..::..Double
The longitude.
Return Value
The time zone, in hours, ranging from +12 hours to -12 hours with 0 being GMT.
Remarks
For some latitude and longitude boundary cases, the time zone calculated may not be correct.
The API offers the ability to adjust the time zone independent of Revit's calculations for situations
where this happens.