Creates a new ElevationMarker.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static ElevationMarker CreateReferenceElevationMarker( Document document, ElementId viewFamilyTypeId, XYZ origin, ElementId viewPlanId ) |
Visual Basic |
---|
Public Shared Function CreateReferenceElevationMarker ( _ document As Document, _ viewFamilyTypeId As ElementId, _ origin As XYZ, _ viewPlanId As ElementId _ ) As ElevationMarker |
Visual C++ |
---|
public: static ElevationMarker^ CreateReferenceElevationMarker( Document^ document, ElementId^ viewFamilyTypeId, XYZ^ origin, ElementId^ viewPlanId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to which the new ElevationMarker will be added.
- viewFamilyTypeId
- Type: Autodesk.Revit.DB..::..ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
- origin
- Type: Autodesk.Revit.DB..::..XYZ
The desired origin for the ElevationMarker.
- viewPlanId
- Type: Autodesk.Revit.DB..::..ElementId
The ViewPlan in which the reference ElevationMarker will appear. Reference ElevationMarkers only appear in one view.
Return Value
The new ElevationMarker.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewPlanId does not correspond to a ViewPlan. -or- This view family type is not appropriate for ElevationMarkers. -or- Elevation view creation is not allowed in this family. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |