Get the PlanTopology of a given level in a given phase.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public PlanTopology this[ Level level, Phase phase ] { get; } |
Visual Basic |
---|
Public ReadOnly Property PlanTopology ( _ level As Level, _ phase As Phase _ ) As PlanTopology Get |
Visual C++ |
---|
public: property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] { PlanTopology^ get (Level^ level, Phase^ phase); } |
Parameters
- level
- Type: Autodesk.Revit.DB..::..Level
The level of the Plan Topology.
- phase
- Type: Autodesk.Revit.DB..::..Phase
The phase of the Plan Topology.
Remarks
Accessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet.
The time necessary for the calculations may be significant and should be considered.