Retrieves or set the symbolic extension status at the end
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
bool this[ int index ] { get; set; } |
Visual Basic |
---|
Property SymbolicExtended ( _ index As Integer _ ) As Boolean Get Set |
Visual C++ |
---|
property bool SymbolicExtended[int index] { bool get (int index); void set (int index, bool value); } |
Parameters
- index
- Type: System..::..Int32
Remarks
Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown.
For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked
at the end. Otherwise the setting is invalid