Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void AppendCondition( RoutingCondition condition ) |
Visual Basic |
---|
Public Sub AppendCondition ( _ condition As RoutingCondition _ ) |
Visual C++ |
---|
public: void AppendCondition( RoutingCondition^ condition ) |
Parameters
- condition
- Type: Autodesk.Revit.DB..::..RoutingCondition
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |