Checks if the element can be an intersection reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool CanBeIntersectionElement( ElementId id ) |
Visual Basic |
---|
Public Function CanBeIntersectionElement ( _ id As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool CanBeIntersectionElement( ElementId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..ElementId
The element to be checked.
Return Value
True if the element can be an intersection reference., false otherwise.
Remarks
The element must be a level, grid, reference plane,
or a curve element whose category is lines and reference lines.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |