Finds the KeyBasedTreeEntry associated with the given key value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public KeyBasedTreeEntry FindEntry( string key ) |
Visual Basic |
---|
Public Function FindEntry ( _ key As String _ ) As KeyBasedTreeEntry |
Visual C++ |
---|
public: KeyBasedTreeEntry^ FindEntry( String^ key ) |
Parameters
- key
- Type: System..::..String
The specified key value.
Return Value
The KeyBasedTreeEntry corresponds to the given key value.
Remarks
If no matching KeyBasedTreeEntry can be found, null will be returned;
The given key value cannot be an empty string.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | key is an empty string. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |