Implement this method to return the id of the service.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
ExternalServiceId GetServiceId() |
Visual Basic |
---|
Function GetServiceId As ExternalServiceId |
Visual C++ |
---|
ExternalServiceId^ GetServiceId() |
Return Value
The id of the service to which the server belongs.
Remarks
An external server belongs to only one external service.
This method must return an Id that matches the Id of the corresponding service was registered with.