Gets or sets a value indicating whether the item is enabled.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool Enabled { get; set; } |
Visual Basic |
---|
Public Property Enabled As Boolean Get Set |
Visual C++ |
---|
public: property bool Enabled { bool get (); void set (bool value); } |
Remarks
When the Enabled property is set to false, the item cannot be clicked,
and the item's appearance changes. The Image and Text assigned to the item appear grayed
out. For pushbuttons, the button may be enabled programmatically but be disabled in the user interface
because of the Revit context; see the property IsEnabledByContext for RibbonButton.