Set the normal of plane in which the hook at end of bar with index barPositionIndex will stay. Will throw exception if the rebar has valid constraints.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
C# |
---|
public void SetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex,
XYZ hookNormal
) |
Visual Basic |
---|
Public Sub SetHookPlaneNormalForBarIdx ( _
end As Integer, _
barPositionIndex As Integer, _
hookNormal As XYZ _
) |
Visual C++ |
---|
public:
void SetHookPlaneNormalForBarIdx(
int end,
int barPositionIndex,
XYZ^ hookNormal
) |
Parameters
- end
- Type: System..::..Int32
The end of bar. Should be 0 for start or 1 for end.
- barPositionIndex
- Type: System..::..Int32
An index between 0 and (NumberOfBarPositions-1).
- hookNormal
- Type: Autodesk.Revit.DB..::..XYZ
The normal of plane in which the hook at end of bar with index barPositionIndex will stay.
Exceptions
See Also