Sets a group of user-created worksets to close.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
public void Close(
	IList<WorksetId> worksetsToClose
)
Visual Basic
Public Sub Close ( _
	worksetsToClose As IList(Of WorksetId) _
)
Visual C++
public:
void Close(
	IList<WorksetId^>^ worksetsToClose
)

Parameters

worksetsToClose
Type: System.Collections.Generic..::..IList<(Of <(<'WorksetId>)>)>
The group of user-created worksets to close. Non-user-created worksets and invalid workset ids will be ignored.

Remarks

Calling this method on a configuration created with options other than WorksetConfigurationOption.CloseAllWorksets will set these worksets to be explicitly closed. If all worksets are set to close, the configuration will be unchanged. Worksets other than the inputs are unaffected.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also