Remove the existing MEPSize with this nominal diameter from the segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void RemoveSize( double nominalDiameter ) |
Visual Basic |
---|
Public Sub RemoveSize ( _ nominalDiameter As Double _ ) |
Visual C++ |
---|
public: void RemoveSize( double nominalDiameter ) |
Parameters
- nominalDiameter
- Type: System..::..Double
The nominal diameter of the size.
Remarks
Does nothing if there is no existing MEPSize with this nominal diameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The last size of the segment cannot be removed. |