Gets the segment ids of this compound structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public IList<int> GetSegmentIds() |
Visual Basic |
---|
Public Function GetSegmentIds As IList(Of Integer) |
Visual C++ |
---|
public: IList<int>^ GetSegmentIds() |
Return Value
The ids of the segments which form the boundary of the regions of this CompoundStructure.
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical
horizontal segments with unique ids.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only for vertically compound structures. |