Returns the ids of all Revisions in the project ordered by sequence number.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static IList<ElementId> GetAllRevisionIds( Document document ) |
Visual Basic |
---|
Public Shared Function GetAllRevisionIds ( _ document As Document _ ) As IList(Of ElementId) |
Visual C++ |
---|
public: static IList<ElementId^>^ GetAllRevisionIds( Document^ document ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document containing the Revisions.
Return Value
The ids of all the Revisions in the document ordered by sequence number.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |