Indicates whether the image type is a link or an import.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public ImageTypeSource SourceType { get; set; } |
Visual Basic |
---|
Public Property SourceType As ImageTypeSource Get Set |
Visual C++ |
---|
public: property ImageTypeSource SourceType { ImageTypeSource get (); void set (ImageTypeSource value); } |
Remarks
Use this property with the method ImageType::Create to create a linked image type.
Use this property with the method ImageType::ReloadFrom to convert an import image type to a link and vice versa.
Valid values are 'Import' and 'Link'.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The ImageType source is not correct. Only Link or Import values are allowed. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |