Sets a cell's to display the specified text.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetCellText( int nRow, int nCol, string text ) |
Visual Basic |
---|
Public Sub SetCellText ( _ nRow As Integer, _ nCol As Integer, _ text As String _ ) |
Visual C++ |
---|
public: void SetCellText( int nRow, int nCol, String^ text ) |
Parameters
- nRow
- Type: System..::..Int32
The cell row.
- nCol
- Type: System..::..Int32
The cell column.
- text
- Type: System..::..String
The text to show in the cell.
Remarks
If this cell's type is not CellType.Text, and the operation is permitted on this cell, the cell type
will be changed to type CellType.Text as a result of this call.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections. |