Returns the visibility settings of a workset for this particular view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public WorksetVisibility GetWorksetVisibility( WorksetId worksetId ) |
Visual Basic |
---|
Public Function GetWorksetVisibility ( _ worksetId As WorksetId _ ) As WorksetVisibility |
Visual C++ |
---|
public: WorksetVisibility GetWorksetVisibility( WorksetId^ worksetId ) |
Parameters
- worksetId
- Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.
Return Value
The visibility of a workset for this particular view.
Remarks
The settings does not reflect the fact of whether a workset is currently closed or not.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document associated with this view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |