The event arguments used by the DocumentSavingAs event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2010

Syntax

C#
public class DocumentSavingAsEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class DocumentSavingAsEventArgs _
	Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class DocumentSavingAsEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
  System..::..EventArgs
    Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
      Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
        Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
          Autodesk.Revit.DB.Events..::..DocumentSavingAsEventArgs

See Also