Exports a Revit project to the Navisworks .nwc format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void Export( string folder, string name, NavisworksExportOptions options ) |
Visual Basic |
---|
Public Sub Export ( _ folder As String, _ name As String, _ options As NavisworksExportOptions _ ) |
Visual C++ |
---|
public: void Export( String^ folder, String^ name, NavisworksExportOptions^ options ) |
Parameters
- folder
- Type: System..::..String
The name of the folder for the exported file.
- name
- Type: System..::..String
The name of the exported file. If it doesn't end in '.nwc', this extension will be added automatically.
- options
- Type: Autodesk.Revit.DB..::..NavisworksExportOptions
Options which control the contents of the export.
Remarks
This is an optional functionality that does not have to be installed. The method "OptionalFunctionalityUtils.isNavisworksExporterAvailable()" can be called to check if the exporter is present.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters -or- The input options were not valid. Check the exception message for specific details. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. |
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist. |
Autodesk.Revit.Exceptions..::..OperationCanceledException | The export operation is cancelled in event handler. |
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | A Navisworks Exporter is not available in the installed Revit. |