Validates if the input name matches the criteria of StructuralConnectionHandlerType name.
Name must be unique among other existing StructuralConnectionHandlerTypes and cannot contain any of the following characters: new line, {}[];`~\\/:*?";<>| or any of the non-printable characters.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
C# |
---|
public static bool IsTypeNameValidForCustomConnection(
Document document,
string typeName
) |
Visual Basic |
---|
Public Shared Function IsTypeNameValidForCustomConnection ( _
document As Document, _
typeName As String _
) As Boolean |
Visual C++ |
---|
public:
static bool IsTypeNameValidForCustomConnection(
Document^ document,
String^ typeName
) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Document.
- typeName
- Type: System..::..String
The StructuralConnectionHandlerType name to validate.
Return Value
True if the input name matches the criteria of StructuralConnectionHandlerType name.
Exceptions
See Also