Indicates whether the workset is visible by default.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsWorksetVisible( WorksetId worksetId ) |
Visual Basic |
---|
Public Function IsWorksetVisible ( _ worksetId As WorksetId _ ) As Boolean |
Visual C++ |
---|
public: bool IsWorksetVisible( WorksetId^ worksetId ) |
Parameters
- worksetId
- Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.
Return Value
Whether the workset is visible by default.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents. |