Direction of the base line of the text element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public XYZ BaseDirection { get; }
Visual Basic
Public ReadOnly Property BaseDirection As XYZ
	Get
Visual C++
public:
property XYZ^ BaseDirection {
	XYZ^ get ();
}

Remarks

Base direction is always perpendicular to Up direction. Those two vectors together define the plane of the text.

See Also