Sets a material element for a specified layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetMaterialId(
int layerIdx,
ElementId materialId
) |
Visual Basic |
---|
Public Sub SetMaterialId ( _
layerIdx As Integer, _
materialId As ElementId _
) |
Visual C++ |
---|
public:
void SetMaterialId(
int layerIdx,
ElementId^ materialId
) |
Parameters
- layerIdx
- Type: System..::..Int32
Index of a layer in the CompoundStructure.
- materialId
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId of a Material element.
Remarks
Exceptions
See Also