Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public ElementCategoryFilter(
	BuiltInCategory category
)
Visual Basic
Public Sub New ( _
	category As BuiltInCategory _
)
Visual C++
public:
ElementCategoryFilter(
	BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::..BuiltInCategory
The category to match.

See Also