Find a definition by id
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public IList<GeometryObject> FindDefinition( string id ) |
Visual Basic |
---|
Public Function FindDefinition ( _ id As String _ ) As IList(Of GeometryObject) |
Visual C++ |
---|
public: IList<GeometryObject^>^ FindDefinition( String^ id ) |
Parameters
- id
- Type: System..::..String
Definition id. Expecected to be unique
Return Value
List of geometry objects that together define a shape
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |