Sets a copy of the given StucturalAsset to be used in the PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public void SetStructuralAsset(
	StructuralAsset structuralAsset
)
Visual Basic
Public Sub SetStructuralAsset ( _
	structuralAsset As StructuralAsset _
)
Visual C++
public:
void SetStructuralAsset(
	StructuralAsset^ structuralAsset
)

Parameters

structuralAsset
Type: Autodesk.Revit.DB..::..StructuralAsset

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also