Identifies if the input element is visible for the temporary view mode for this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsElementVisibleInTemporaryViewMode( TemporaryViewMode mode, ElementId id ) |
Visual Basic |
---|
Public Function IsElementVisibleInTemporaryViewMode ( _ mode As TemporaryViewMode, _ id As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsElementVisibleInTemporaryViewMode( TemporaryViewMode mode, ElementId^ id ) |
Parameters
- mode
- Type: Autodesk.Revit.DB..::..TemporaryViewMode
The temporary view mode. Only TemporaryHideIsolate and AnalyticalModel modes are supported by this option. Other modes will result in an exception.
- id
- Type: Autodesk.Revit.DB..::..ElementId
The element id.
Return Value
True if the element is visible, false if the element is hidden in the view mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | This view mode is not supported for checking element visibility. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |