Gets the host face to which the CurveElement is added.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static Reference GetHostFace( CurveElement curveElem ) |
Visual Basic |
---|
Public Shared Function GetHostFace ( _ curveElem As CurveElement _ ) As Reference |
Visual C++ |
---|
public: static Reference^ GetHostFace( CurveElement^ curveElem ) |
Parameters
- curveElem
- Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.
Return Value
The host face to which the CurveElement is added, or an empty Reference if the host is not a face.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |