The portion of the curve to be selected.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public AnalyticalCurveSelector CurveSelector { get; set; }
Visual Basic
Public Property CurveSelector As AnalyticalCurveSelector
	Get
	Set
Visual C++
public:
property AnalyticalCurveSelector CurveSelector {
	AnalyticalCurveSelector get ();
	void set (AnalyticalCurveSelector value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also