The name for the assembly type.
All matching assembly instances share this name.
Unique assembly instances are named automatically based on their naming category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public string AssemblyTypeName { get; set; } |
Visual Basic |
---|
Public Property AssemblyTypeName As String Get Set |
Visual C++ |
---|
public: property String^ AssemblyTypeName { String^ get (); void set (String^ value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: This assembly type name is not valid for this assembly instance. An assembly type name should be non-empty, should contain valid characters, and should be unique for its naming category. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |