Imports a FamilySizeTable from a CSV file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool ImportSizeTable( Document document, string filePath, FamilySizeTableErrorInfo errorInfo ) |
Visual Basic |
---|
Public Function ImportSizeTable ( _ document As Document, _ filePath As String, _ errorInfo As FamilySizeTableErrorInfo _ ) As Boolean |
Visual C++ |
---|
public: bool ImportSizeTable( Document^ document, String^ filePath, FamilySizeTableErrorInfo^ errorInfo ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
Family owned document or project document.
- filePath
- Type: System..::..String
The CSV file path.
- errorInfo
- Type: Autodesk.Revit.DB..::..FamilySizeTableErrorInfo
An error object to be written to if errors occur.
Return Value
True if successful, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |