Collects the ids of all StructuralConnectionApprovalTypes in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public static void GetAllStructuralConnectionApprovalTypes(
	Document cda,
	out ICollection<ElementId> ids
)
Visual Basic
Public Shared Sub GetAllStructuralConnectionApprovalTypes ( _
	cda As Document, _
	<OutAttribute> ByRef ids As ICollection(Of ElementId) _
)
Visual C++
public:
static void GetAllStructuralConnectionApprovalTypes(
	Document^ cda, 
	[OutAttribute] ICollection<ElementId^>^% ids
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>%

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also