Gets the DocumentVersion that corresponds to a document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static DocumentVersion GetDocumentVersion( Document doc ) |
Visual Basic |
---|
Public Shared Function GetDocumentVersion ( _ doc As Document _ ) As DocumentVersion |
Visual C++ |
---|
public: static DocumentVersion^ GetDocumentVersion( Document^ doc ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The document whose DocumentVersion will be returned.
Return Value
The DocumentVersion corresponding to the given document.
Remarks
This function can be combined with IsModified
to see whether a document in memory is different from a version on disk. The documents
are different if the document is modified or if the two DocumentVersions differ.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |