Checks whether the family symbol id is allowed for
StructuralConnectionTypes with the given value for the applyTo
property.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool ValidFamilySymbolId( Document doc, StructuralConnectionApplyTo applyTo, ElementId familySymbolId ) |
Visual Basic |
---|
Public Shared Function ValidFamilySymbolId ( _ doc As Document, _ applyTo As StructuralConnectionApplyTo, _ familySymbolId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool ValidFamilySymbolId( Document^ doc, StructuralConnectionApplyTo applyTo, ElementId^ familySymbolId ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
- familySymbolId
- Type: Autodesk.Revit.DB..::..ElementId
Return Value
True if %familySymbolId% is invalidElementId; or if it is the id of a FamilySymbol of category "Connection Symbols" (OST_StructConnectionSymbols) with its "Apply To" parameter set to match the applyTo property. Returns false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |