Sets a column's category and parameter Id
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetCellParamIdAndCategoryId( int nCol, ElementId paramId, ElementId categoryId ) |
Visual Basic |
---|
Public Sub SetCellParamIdAndCategoryId ( _ nCol As Integer, _ paramId As ElementId, _ categoryId As ElementId _ ) |
Visual C++ |
---|
public: void SetCellParamIdAndCategoryId( int nCol, ElementId^ paramId, ElementId^ categoryId ) |
Parameters
- nCol
- Type: System..::..Int32
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given column number nCol is invalid. -or- The paramId or categoryId is not acceptable. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is forbidden for cells in standard schedule body sections. |