Get the length for the specified segment id in this section.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public double GetSegmentLength( ElementId segmentId ) |
Visual Basic |
---|
Public Function GetSegmentLength ( _ segmentId As ElementId _ ) As Double |
Visual C++ |
---|
public: double GetSegmentLength( ElementId^ segmentId ) |
Parameters
- segmentId
- Type: Autodesk.Revit.DB..::..ElementId
The element id which can be duct segment and pipe segment.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId segmentId does not correspond to a valid section segment member. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |