Returns the family symbol of the profile.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilySymbol Profile { get; set; } |
Visual Basic |
---|
Public Property Profile As FamilySymbol Get Set |
Visual C++ |
---|
public: property FamilySymbol^ Profile { FamilySymbol^ get (); void set (FamilySymbol^ value); } |
Remarks
The symbol must of the category BuiltInCategory.OST_ProfileFamilies.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the category of argument is not BuiltInCategory.OST_ProfileFamilies. |