Remove segments from the hosted sweep object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void RemoveSegment( Reference targetRef ) |
Visual Basic |
---|
Public Sub RemoveSegment ( _ targetRef As Reference _ ) |
Visual C++ |
---|
public: void RemoveSegment( Reference^ targetRef ) |
Parameters
- targetRef
- Type: Autodesk.Revit.DB..::..Reference
Segment's reference which want to be removed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails. |