Gets the document associated with the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2020

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
	Get
Visual C++
public:
property Document^ Document {
	Document^ get ();
}

Remarks

The document is in read-only state. Transactions are not allowed in it.

See Also