Creates one conduit standard type with the new name and assign the conduit sizes to it from the existing standard type.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
C# |
---|
public bool CreateConduitStandardTypeFromExisingStandardType(
Document pADoc,
string newStandardName,
string existingStandardName
) |
Visual Basic |
---|
Public Function CreateConduitStandardTypeFromExisingStandardType ( _
pADoc As Document, _
newStandardName As String, _
existingStandardName As String _
) As Boolean |
Visual C++ |
---|
public:
bool CreateConduitStandardTypeFromExisingStandardType(
Document^ pADoc,
String^ newStandardName,
String^ existingStandardName
) |
Parameters
- pADoc
- Type: Autodesk.Revit.DB..::..Document
The document.
- newStandardName
- Type: System..::..String
The new conduit standard name.
- existingStandardName
- Type: System..::..String
The existing conduit standard name.
Return Value
True if creating success; otherwise false.
Exceptions
See Also